What version of ActiveTcl should I use with Windows Vista?

Posted by kevinw on 2007-01-15 16:50
OS: Windows Vista | Product: ActiveTcl | tags: compatibility tcl vista windows
Question: 

What version of ActiveTcl should I use with Windows Vista?

Answer: 

The best version of Tcl to use with Windows Vista is ActiveTcl 8.4.14 or later.

There are currently minor issues with installing and uninstalling, but these are not serious and are being worked on. The demo applications distributed with ActiveTcl all function as expected, including the graphical libraries and Expect.

Note that you will need to right-click the installation file and select "Run as Administrator" for the installation to be successful. This will be fixed in a future release of ActiveTcl.

AndyGaskell | Thu, 2007-01-18 07:54

Hi All
We're an ActiveState OEM partner for ActiveTcl, we currently ship 8.4.8.0 with our product, does anyone know of any issues with this and Windows Vista? 32 bit or 64 bit?

kevinw
ActiveState Staff
Tue, 2007-01-23 11:06

Hi Andy,

JeffH says that the caveats with 8.4.8 will be roughly the same as 8.4.14. We are not aware of any more serious issues at this point. I have not tested 8.4.8 on Vista; only 8.4.14.

Cheers,

kjw

AndyGaskell | Thu, 2007-02-01 03:06

we'll update our software install to use 8.4.14 on the next release, thanks for your reply.

cgchoffman
ActiveState Staff
Tue, 2012-01-17 10:59

Update:

8.4, 8.5, and 8.6 all run on XP to Windows 7.

-Carey

vinodkumar01 | Mon, 2012-07-02 06:59

What version of ActiveTcl should I use with Windows 2008 R2 ?

i currenly have 8.4.2.19 on the machine..

And when i run , i get event name: APP CRASH
: tclsh.exe 8.4.2.19
fault module time stamp: 4fee27af
Exception code :c0000005
Exception offset:000cd4fd