TDK 4.0.2 needs Tcl 8.5?

Posted by grahams on 2007-10-16 13:54
OS: All / Any | Product: Tcl Dev Kit | tags: compile tbcload tdk

I've installed TclDevKit 4.0.2 and ActiveTcl 8.4.16 to compile my Tcl scripts. The problem is that the .tbc files generated by the Tcl Compiler
are only usable with tbcload 1.7 and only for Tcl 8.5. The message in the installation dialog suggests to take the packages from an Tcl 8.4 distribution.


TDK 4.0 comes with support for both 8.4 and 8.5. The unversioned tclcompiler executable is for 8.5, and tclcompiler84 is for 8.4. If you are using TclApp and the checkbox for this, there is a version specifier combobox right next to it for your convenience. In addition, it will auto-detect the version of the basekit you are using.

tcltry | Wed, 2009-08-19 09:06

I got the below message:
if {[catch {package require tbcload 1.6} err] == 1} {
return -code error "[info script]: The TclPro ByteCode Loader is not available or does not support the correct version -- $err".

How do I correct this error to make my script run?
Am I missing tbcload1.4 or tclPro?
If yes how can I get these files loaded?
I'm totally new to tcl and I'm using the 21 days trial. Please help!!!

teltech | Sun, 2010-09-12 23:56

Questions should probably go to the forum, but have you tried telling your program where the tbcload package is? For example:

export TCLLIBPATH=/opt/ActiveTcl-8.5/lib/tcl8.5; ./myProg.tbc