My installation package could not be opened.

Posted by jeff.griffiths on 2007-05-07 11:50
OS: Windows | Product: ActivePerl | tags: install msi
Question: 

I downloaded Activeperl form your website, but when I go to start the installation process I get this error:

"This installation package could not be opened. Contact the application vendor to ensure that this is a valid installer package."

What is wrong?

Answer: 

This error message *always* indicates that the MSI installation package has been corrupted during the download. You will need to re-download.

It is very common to get repeated bad downloads. Please remember to flush your local cache, or switch to a different browser program. Also remember that the bad file is likely cached at your ISP, so you may have to wait a while before the bad cache is cleared.

You can verify the downloaded file against the MD5SUMS published in each download directory:

http://downloads.activestate.com/ActivePerl/Windows/5.10/MD5SUM ( 5.10 )
http://downloads.activestate.com/ActivePerl/Windows/5.8/MD5SUM ( 5.8 )

You can get a tool to generate md5sum hashes from here:
http://www.pc-tools.net/win32/md5sums/

Often you can get past a cache issue by navigating to the file differently. You might have better luck starting from here:

http://downloads.activestate.com/ActivePerl/releases/

Fletch Glancy | Mon, 2007-05-14 08:31

I also get a comment that the package cannot be opened. I have downloaded it from the FTP Server several times over the last day and continue to not be able to open Active Perl. I am running Windows XP. Are there settings that need to be changed to open the program?

jeff.griffiths | Mon, 2007-05-14 09:22

I have seen situations where users behind a caching proxy server either on their network or at their ISP will keep getting a broken, cached copy of the file instead of the real file on our site. Did you generate an md5 string using the file you downloaded and compare it to the one on our ftp? Is it possible for you to try downloading using your home internet connection?

--
JeffG

kk54 | Thu, 2010-06-24 08:52

I have also a problem downloading, when I am saving Iget this message:

(ActivePerl-5.10.1.1007-MSWin32-x86 291969.msi
A required privilage is not held by the client).

I dont know what to do, any help pls

grahams
ActiveState Staff
Thu, 2011-05-05 12:39

This is a Windows permissions problem.

Always save the file to a local hard drive. MSI installers will have issues if they are run from or attempt to install to a network share or a removable drive.

First, try saving the MSI file to your desktop and running it from there.

There are some valid configurations for Windows where this will not be enough. If it is not possible to install from a file saved to your desktop, you may need to move the MSI file to C:\ and run the installer from there.

arthur08 | Wed, 2010-07-21 08:20

I managed to create a user but it is not connected to the account I was given so it expects me to pay again to actiate the account.

arthur08 | Wed, 2010-07-21 08:27

*Serial number removed by forum administrator*

On first time of using.

So I have user but it is not linked to licence.

grahams
ActiveState Staff
Thu, 2011-05-05 12:51

Our licensing system indicates that the serial number you provided is already assigned to a different user ID. Your license administrator could re-assign the license to you if that is what is needed. If you do not know who the license administrator in your company is, you can contact ActiveState Customer Service for that info.
http://www.activestate.com/company/contact-us