Performance problems with remote User profiles

Posted by jeff.griffiths on 2007-11-20 17:23
OS: Windows | Product: Komodo | tags: komodo preferences window
Question: 

Komodo performs badly on my Laptop when I am at work on my company network, but works fine when I'm at home. How do I fix this?

Answer: 

This is possibly because your Company's network uses roaming or remote profiles, so when you are at work your User profile directory ( including Komodo's preferences ) are stored on a remote server. The best way to work around this is to instead store your preferences in a different directory on your machines local drive, outside of your user profile area.

1. create a new environment variable called 'KOMODO_USERDATADIR' and set it to a local path such as 'C:\KomodoPrefs\':

- right-click on My Computer and select Properties
- click on the Advanced tab and hit the Environment button towards the bottom
- below the System Variables list, click on the 'New' button
- for 'Variable name' fill in KOMODO_USERDATADIR, for 'Variable value' fill in your local path.

2. Start Komodo. This will create a new set of preferences in the local directory, and hopefully improve performance.