How to prevent freeze-ups on dual-core Windows machines

Posted by ericp on 2007-06-20 12:19
OS: Windows | Product: Komodo | tags: core debugging dual dual-core freeze windows
Question: 

I run Komodo on a dual-core Windows machine. Occasionally after running a Perl program, either inside the debugger or outside, Komodo will freeze up. This seems to happen whether the CPU is Athlon or Pentium, it doesn't seem to matter.

Answer: 

The key is to open the task manager, select the komodo.exe process, right-click
it using the "set affinity" function.

Remove the checkmark from all but one CPU and komodo will work fine.

Thanks to community contributor JTa for working this out.

You can track this bug at
http://bugs.activestate.com/show_bug.cgi?id=53927

hebetude | Fri, 2007-09-07 04:45

How to (really) fix this. The above solution has to be repeated over&over each time you start komodo. You can also have it done at some sort of system level with a tool called ImageCFG.exe (NT based operating systems only Windows NT, 2000 Family, XP Family, 2003 Family, Longhorn/Vista). This is all copy/pasted from the linked website.

Go here to download it: Robopol86.com - ImageCFG.exe

Instructions:
Copy imagecfg.exe to %systemroot%\system32 (or C:\Windows\system32), and %systemroot%\system32\dllcache (or C:\Windows\system32\dllcache).

Open up Start->Run and execute:
imagecfg -u komodo.exe
You may have to include the path to file C:\Program Files\Activestate yada yada, but mine worked without that.

This basically tells Windows to run this as a Uniprocessor application. You can specify which cpu(core) to use by using the -a option. For example, to always use the 2nd core/cpu do
imagecfg -a 0x2 komodo.exe

Frankly, the option to "internally" change komodo to a uni-processor application should be set (until bug is resolved). These types of tools are only useful for linking a editor with a debug/compiling tool and Komodo apparently crashes in this situation on Dual-Core machines.