How to improve Komodo's editing performance

Posted by toddw on 2007-08-17 15:18
OS: All / Any | Product: Komodo | tags: komodo performance
Question: 

In what ways can I increase the performance of the Komodo application?

Answer: 

There are numerous components inside of Komodo that can become a performance hindrance, especially on older computing machines. Luckily, there are a number of features and components that can be turned off. Here are a few of these most common performance sensitive components that can be disabled:

  • Code Intelligence autocomplete and calltips (fires from editor key press events)
  • Syntax checking, aka linting (fires after code changes)
  • Disable wordwrap, as this can become intensive for files with long lines
  • Disable folding, this intensifies the code parsing process
  • Ensure there are no mixed line endings (will show up as green squiggles)
  • If using Komodo IDE SCC integration, ensure the "Do recursive status checks" preference is turned off

Startup ideas

  • Reduce the number of opened files and projects? As this is a large contributor to the startup speed.

Platform specific ideas

  • Mac OS X: Ensure you are using the correct build for your Mac architecture, check the "Komodo->About" menu, it should be macosx-x86 if you have an Intel machine, else macosx-powerpc for PowerPC. See here on how to check your system: http://support.apple.com/kb/HT1531

Feel free to add others as you come across them.

Cheers,
Todd

Andes_Help | Thu, 2008-01-03 10:22

According to your information here the wordwrap option is defaulted to "On". Yet, in the Komodo Edit 4.1 it is defaulted to "Off" and I can not find a way to turn it to a default of "On". I am converting a group of documents to different formats for use on a website. But, had to give up when I had to keep manually turning the wordwrap option to "On" for each new page and document.
How do I get this option to be set to default "On"?
Thanks

toddw
ActiveState Staff
Thu, 2008-01-03 12:18

Yes, the wordwrap setting is set to "Off" by default (there was no mention of it being "On" by default, the tips above are not specific to Komodo's default settings, but are rather general performance tips).

You can set the wordwrap setting to be "On" by default by going into Komodo's global preferences (using the Edit->Preferences menu, or About->Preferences menu on a Mac). Navigate to the "Editor->Smart Editing" category and change the "Wrap long lines by:" setting to "Word" or "Character", as you prefer.

After setting this, all files opened in Komodo should be using wordwrap and wrapping the text where it would otherwise disappear off to the right of the screen. The only exception to this is if you've actually set the wordwrap setting on the file itself (overriding the global preference) to be "Off". The current file override settings can be seen through the "Edit->Current file settings" menu.

If this is not occurring then it is a Komodo bug and I encourage you to report the problem at:
http://bugs.activestate.com/enter_bug.cgi?product=komodo

Cheers,
Todd

Andes_Help | Thu, 2008-01-03 17:00

Thank You for your quick response. I have a new laptop with Vista installed and my favorite application, Alleycode, will not work with Vista.

So, I am searching for something else to use for developing websites with HTML and CSS. Most of my customers have a lot of documents and publications which I have to manually convert from ASCII text for the websites.

My latest project had 117 publications which were converted to HTML, Word, and Adobe PDF.

dannygrimes | Wed, 2010-05-26 07:16

Thanks for this. Love the editor but hate the non-auto word wrap. Now we are all good.

endat | Thu, 2010-11-18 14:05

I am using Komodo IDE 5.2 and the line wrap constantly turns itself on at random. I go to the preferences and says "none" so it appears to be turned off. The only way to turn it back off is to turn it on, hit OK, go back to preferences, and turn it off again. This is getting really annoying, here is my program information:

Komodo IDE, version 5.2.4, build 37659, platform win32-x86.
Built on Tue Dec 08 19:50:12 2009.

toddw
ActiveState Staff
Fri, 2010-11-19 16:54

I haven't seen this behaviour.

Do you ever use (or accidentally hit) the "Ctrl+9" keybinding, as that matches the "View->Word Wrap" command?

Cheers,
Todd